服务linux器自带的是python2.6.无法安装 pip install paramiko。总是报错。

系统自带的Python2.6又不能动。无奈只好再安装一个版本。

自己尝试手动升级python2.7 最后还是放弃了,因为安装成功了,pip等组件也没法使用,尴尬。

最终, 还是改为用anaconda辅助安装python3..(阿里云服务器,下载安装特别快)。。具体步骤如下:

1.下载安装脚本:wgethttps://repo.anaconda.com/archive/Anaconda3-5.2.0-Linux-x86_64.sh

2.运行安装向导:bashAnaconda3-5.2.0-Linux-x86_64.sh

一路 enter 或 yes

3.修改环境变量

(这样系统默认Python3了,且默认使用pip也是pip3了)

使环境变量立即生效

确认是否安装成功:

echo"export PATH=/root/anaconda3/bin:$PATH">> /etc/profile

source/etc/profile

conda --version

4.建软连接

这样才能保证脚本中调用python3不用写绝对路径

ln-s /usr/bin/python2. 6/usr/bin/python

rm -f /usr/bin/python

ln -s /root/anaconda3/bin/python /usr/bin/python

5.测试

在linux终端打开python,若是下面的界面表示成功

注:系统自带的Python是2.6,安装anaconda3会自动升级Python版本

尴尬!,升级到python3后,yum命令不能执行了。

解决办法:

vi/usr/bin/yum

将行首#!/usr/bin/python 改为 #!/usr/bin/python2.6