一个老洞可能让亚马逊Echo和Kindle“躺枪”

原标题:一个老洞可能让亚马逊Echo和Kindle“躺枪”

今天是第 307 次,Echo又毫无例外地用语音问老王账户密码是多少。

同样抽风的,还有老王的 Kindle,这本电子书也会每天不止一次地蹦出输入框,要求自己输入账户密码。

老王要疯,这两货是中了什么毒?

比中毒还可怕的是,老王的两台设备是中了黑客的重放攻击,毕竟,老王是银行卡有八位数的隔壁老王嘛!

呵呵哒,就算卡里没有几毛钱,此类诡异状况,同样有可能被更多的 Echo 和 Kindle 用户撞上。

因为,这些设备都存在着同一漏洞:

2007年,两位比利时研究人员Mathy Vanhoef和Frank Piessens公布了一项令人惊讶的研究成果——他们发现WPA2标准存在严重缺陷(该协议当时在保护几乎所有现代Wi-Fi网络),其被称为KRACK(密钥重装攻击)漏洞。

时隔两年,许多启用 Wi-Fi 的设备仍然容易受到 KRACK 攻击。这其中,就包括亚马逊的第一款人工智能音响 Echo 和第 8 代 Kindle 电子书。

2007年,两位比利时研究人员Mathy Vanhoef和Frank Piessens公布了一项令人惊讶的研究成果——他们发现WPA2标准存在严重缺陷(该协议当时在保护几乎所有现代Wi-Fi网络),其被称为KRACK(密钥重装攻击)漏洞。

时隔两年,许多启用 Wi-Fi 的设备仍然容易受到 KRACK 攻击。这其中,就包括亚马逊的第一款人工智能音响 Echo 和第 8 代 Kindle 电子书。

亚马逊旧产品“躺枪”

之所以说躺枪,是因为 KRACK 漏洞属于协议级别问题,所有实施该协议标准的软硬件都会受到影响。

仅在美国,亚马逊就销售了数千万台 Echo 设备,以及数千万台第八代 Kindle,而这些设备携带的 KRACK 漏洞让安全风险延续至今。

利用这种手段,攻击者能够读取之前被认为是安全加密的信息,从而盗取诸如信用卡号、口令、聊天信息、邮件、照片等各种敏感信息。

作为研究的一部分,最早发现问题的研究人员利用 Vanhoef 团队提供的脚本,针对第一代亚马逊硬件产品进行了着重设备对各种 KRACK 漏洞恢复能力的测试。

“使用 Vanhoef 的脚本,我们能够在四次握手(CVE-2017-13077)中复制重新安装成对加密密钥(PTK-TK),并在四次握手(CVE-2017-13077)中复制组密钥(GTK)CVE-2017-13078)。”研究人员发现,Alexa Echo 和第 8 代 Kindle 电子书易受上述 KRACK 漏洞影响。

由于攻击主要针对四次握手,所以攻击目标为客户端为而不是访问点,因此作为 PoC(概念验证)这种攻击对于 Linux 和安卓 6.0 以上版本设备是毁灭性的。

该研究人员称,这些漏洞非常严重,它们使攻击者能够:

重播旧数据包以执行 DoS 攻击,破坏网络通信或重播攻击

解密受害者传输的任何数据或信息

取决于网络配置:伪造数据包,导致设备关闭数据包甚至注入新数据包

拦截敏感信息,例如密码或会话 cookie

重播旧数据包以执行 DoS 攻击,破坏网络通信或重播攻击

解密受害者传输的任何数据或信息

取决于网络配置:伪造数据包,导致设备关闭数据包甚至注入新数据包

拦截敏感信息,例如密码或会话 cookie

而从两年前 Vanhoef 的研究结论来看,避免 KRACK 漏洞的最有效办法就是联系各种无线设备提供商,查看是否需要更新协议,而最直接的办法就是禁用 WPA2。

在办公场所,Vanhoef则建议禁止路由器上的客户端功能,禁用访问点(AP),禁用802.11r协议。

黑客把戏:重放攻击

这次发现的 KRACK 漏洞允许黑客使用广播重放攻击来“愚弄”用户。

通常情况下,攻击者会发送一个目的主机已接收过的包,来达到欺骗系统的目的。这种行为主要用于身份认证过程,破坏认证的正确性。

重放攻击可以由发起者,也可以由拦截并重发该数据的敌方进行。攻击者利用网络监听或者其他方式盗取认证凭据,之后再把它重新发给认证服务器。

对于 Echo 设备,攻击者可以滥用此低级攻击来发起拒绝服务(DoS)攻击或收集数据包以用于将来的密码分析或蛮力攻击。

值得注意的是,KRACK 漏洞需要紧密接近才可。因此,执行攻击的前提是攻击者和受害者设备都必须位于同一Wi-Fi无线网络的范围内。

因此,研究人员觉得针对亚马逊设备(可能还有其他设备)的攻击也不太可能显著影响通过网络发送的信息安全性。

这要归功于敏感数据的大部分受到了标准WPA / WPA2加密(即使用TLS加密的HTTPS)之外的其他安全措施的保护。

报告和修补

2018 年 10 月 23 日,研究人员将所有发现的问题一五一十上报给了亚马逊,并提醒后者尽快进行修补。

2019 年 1 月 8 日,研究人员收到亚马逊确认邮件,邮件中表示已经复制了问题内容,准备了补丁,并将在未来几周内分发给用户。

截止目前,亚马逊已经发布该补丁修复了 Echo 和 Kindle 8 存在的问题,并在客户端设备上的软件应用程序加入对 Wi-Fi 网络进行身份验证。

研究人员建议,所有亚马逊用户升级最新的系统,并通过其Echo应用程序和Kindle设置来验证是否正在使用最新的Echo和Kindle固件。

参考来源:welivesecurity

更多精彩内容敬请关注雷锋网网络安全栏目或雷锋网旗下为信公众号宅客频道。雷锋网返回搜狐,查看更多

责任编辑:

声明:该文观点仅代表作者本人,搜狐号系信息发布平台,搜狐仅提供信息存储空间服务。
免费获取
今日搜狐热点
今日推荐